Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-95797

Qt 5.12.11 Qt5QuickCompiler

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Invalid
    • Affects Version/s: 5.12.11
    • Fix Version/s: 5.15
    • Component/s: QML: Compiler
    • Environment:
      Embedded device, with NXP iMX6ULL.

      Description

      I am using Qt 5.12.11, my application run correctly if cmake with below

      add_executable(${PROJECT_NAME} ${SOURCE_FILES} ${QRC_FILES})

       

      However if I enable Qt5QuickCompiler as below:

      find_package(Qt5QuickCompiler)

      qtquick_compiler_add_resources(RESOURCES ${QRC_FILES})

      add_executable(${PROJECT_NAME} ${SOURCE_FILES} ${RESOURCES})

      Application will print below error message: 

      File was compiled ahead of time with an incompatible version of Qt and the original file cannot be found. Please recompile

       

      No idea why this happened.

       

       

       

       

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qtqmlteam Qt Qml Team User
            Reporter:
            allan-zhang Allan Zhang
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes