Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-97673

Update dependencies in qt/qtshadertools fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P0: Blocker
    • Resolution: Done
    • Affects Version/s: 6.2.2, 6.3.0 Feature Freeze
    • Fix Version/s: 6.3.0 Alpha
    • Component/s: Build System: CMake
    • Labels:
      None
    • Commits:
      8d1db12bba73ad0b74723e58ad0f1f3134767a36 (qt/qtbase/dev) 5049cdb87521e2ef5a68a85126b7fd2c4eb13d07 (qt/qtbase/6.2) 606124c5cceba0dd4a406a9278588b58bb9f9800 (qt/qtbase/dev) 5f142695bc6f634378c1fabd508eaa609645af57 (qt/qtbase/6.2)

      Description

      CMake Error at /home/qt/work/install/lib/cmake/Qt6BuildInternals/StandaloneTests/QtShaderToolsTestsConfig.cmake:1 (find_package):
      agent:2021/10/21 04:34:48 build.go:393:   Found package configuration file:
      agent:2021/10/21 04:34:48 build.go:393:     /home/qt/work/install/lib/cmake/Qt6/Qt6Config.cmake
      agent:2021/10/21 04:34:48 build.go:393:   but it set Qt6_FOUND to FALSE so package "Qt6" is considered to be NOT
      agent:2021/10/21 04:34:48 build.go:393:   FOUND.  Reason given by package:
      agent:2021/10/21 04:34:48 build.go:393:   Failed to find Qt component "ShaderTools".
      agent:2021/10/21 04:34:48 build.go:393:   Expected Config file at
      agent:2021/10/21 04:34:48 build.go:393:   "/home/qt/work/install/lib/cmake/Qt6ShaderTools/Qt6ShaderToolsConfig.cmake"
      agent:2021/10/21 04:34:48 build.go:393:   exists
      agent:2021/10/21 04:34:48 build.go:393:   
      agent:2021/10/21 04:34:48 build.go:393: Call Stack (most recent call first):
      agent:2021/10/21 04:34:48 build.go:393:   /home/qt/work/install/lib/cmake/Qt6BuildInternals/Qt6BuildInternalsConfig.cmake:581 (include)
      agent:2021/10/21 04:34:48 build.go:393:   tests/CMakeLists.txt:7 (qt_build_tests)
      agent:2021/10/21 04:34:48 build.go:393: -- Configuring incomplete, errors occurred!
      

      Build log: https://testresults.qt.io/logs/qt/qtshadertools/040c476e74481a05a9e0f190908b2740c15fc8df/LinuxopenSUSE_15_3x86_64LinuxopenSUSE_15_3x86_64GCCqtci-linux-openSUSE-15.3-x86_64-50-27da6fSccache/7682dbeb02d67b509ae9421f809f4efd232faa0b/build_1634791503/log.txt.gz

      Details: https://testresults.qt.io/coin/integration/qt/qtshadertools/tasks/1634791494

      Tested changes (refs/builds/qtci/6.2/1634790838):
      https://codereview.qt-project.org/c/qt/qtshadertools/+/377717/3 Update dependencies on '6.2' in qt/qtshadertools

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            alexandru.croitor Alexandru Croitor
            Reporter:
            janihe Jani Heikkinen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes