Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-97897

Tooltips hide by themselves almost immediatelly when launched from QWebEngineView

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 6.2.0
    • Fix Version/s: 6.3.0 Alpha
    • Component/s: WebEngine
    • Labels:
      None
    • Platform/s:
      All
    • Commits:
      1a3a932926e4135cb055c02d89117b0a652a374d (qt/qtwebengine/dev)

      Description

      It is the same as https://lists.qt-project.org/pipermail/qt-interest-old/2011-October/036210.html

      1. Use "&QWebEnginePage::linkHovered" signal.
      2. Call "QToolTip::showText(QCursor::pos(), url, {}, {}, 6000);" in the attached slot.

      Shown tooltip displays almost immediately after showint itself, like 200 ms. 6000 ms argument is not taken into account at all. Also, mouse is not moved at all when tooltip displays.

      GIF attached.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              pvarga Peter Varga
              Reporter:
              skunkos Martin Rotter
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes