Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-97931

CMake warning about linked plugins in Qt Data Visualization

    XMLWordPrintable

    Details

    • Commits:
      ecb014566ad827800480f716329f245fb2cc6cd4 (qt/qtdatavis3d/dev) 8b4cb7eca3ae2d9bf5d879c94dc895329074bb74 (qt/qtdatavis3d/6.2)

      Description

      Running configure in 6.2 branch of qtdatavis3d gives following CMake warning:

      Configuring 'qtdatavis3d'
      -- Running syncqt for module: 'QtDataVisualization' 
      CMake Warning (dev) at qtbase/cmake/QtPluginHelpers.cmake:57 (message):
        Plugins are not intended to be linked to.  They should not have any public
        properties, but DataVisualizationQml2 sets PUBLIC_LIBRARIES to the
        following value:
      
            Qt::Core;Qt::Gui;Qt::OpenGL;Qt::Qml;Qt::Quick;DataVisualization
      
        Update your project to use LIBRARIES instead.
      
      Call Stack (most recent call first):
        C:/dev/qt/6.2/test/qtbase/lib/cmake/Qt6Qml/Qt6QmlBuildInternals.cmake:220 (qt_internal_add_plugin)
        qtdatavis3d/src/datavisualizationqml2/CMakeLists.txt:26 (qt_internal_add_qml_module)
      This warning is for project developers.  Use -Wno-dev to suppress it.
      

        Attachments

        For Gerrit Dashboard: QTBUG-97931
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            qtbuildsystem Qt Build System Team
            Reporter:
            kkohne Kai Köhne
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes