Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-98753

hover is not longer working after link out

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 6.2.1
    • Fix Version/s: None
    • Labels:
      None

      Description

      When you have a QML app with a button that opens a browser, if you click back into the project after being sent to the browser the hover state no longer works. You can continue to press the button and this will activate the pressed state but to get the hover back you need to either mouse over the app header bar (no click needed) or click on the app icon in the dock. After doing this all focus is returned to normal.

      Attached a basic qds project and video showing the issue.

       

      macOS Version 12.0.1

        Attachments

        1. HoverFocusMacOS.zip
          16 kB
        2. macQMLFocus.mp4
          1.16 MB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt.team.quick.subscriptions Qt Quick and Widgets Team
            Reporter:
            brook_cronin_qt Brook Cronin
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes