Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99063

static top-level developer configuration fails in qtdeclarative doc snippet

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.2.2, 6.3
    • Fix Version/s: 6.3.1, 6.4.0 Beta1
    • Component/s: Build System: CMake
    • Labels:
      None
    • Platform/s:
      All
    • Commits:
      af93406a7d (qt/qtdeclarative/dev) af93406a7d (qt/tqtc-qtdeclarative/dev) a914b34752 (qt/qtdeclarative/6.3) a914b34752 (qt/tqtc-qtdeclarative/6.3)

      Description

      How to reproduce:

      • configure a top-level build of qtbase, qtshadertools and qtdeclarative with the configure flags -static -developer-build

      configure fails with

      CMake Error: AUTOMOC for target qt_target_qml_sources_example_resources_1: The "moc" executable "/home/jobor/dev/qt/dev-top-level/qtbase/libexec/moc" does not exist.
      

      This error stems from qtdeclarative/doc/snippets/cmake/qt_target_qml_sources

        Attachments

        For Gerrit Dashboard: QTBUG-99063
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            qtbuildsystem Qt Build System Team
            Reporter:
            jbornema Joerg Bornemann
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: