Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99273

QtDeclarative fails to configure when Python is not in PATH but is found via FindPython

    XMLWordPrintable

    Details

    • Commits:
      e0eb75b2a0 (qt/qtdeclarative/dev) cf497f857c (qt/qtdeclarative/6.2) fbbe5f2946 (qt/qtdeclarative/6.3) cf497f857c (qt/tqtc-qtdeclarative/6.2) fbbe5f2946 (qt/tqtc-qtdeclarative/6.3) e0eb75b2a0 (qt/tqtc-qtdeclarative/dev) cf497f857c (qt/qtdeclarative/6.2.4)

      Description

      I'm trying to build QtDeclarative but am hitting a wall.

      The environment is as follows:

      • Qt 6.2.2 is installed (mingw build from the installer)
      • Windows 10
      • perl is installed and callable in CMD (aka, path is fine)
      • python 3.x is installed and callable in CMD (aka, path is fine)

      The cmake output is the following:

       

      Running C:\Qt\Tools\CMake_64\bin\cmake.exe -S D:/code/qtdeclarative -B D:/code/build-qtdeclarative-Desktop_Qt_6_2_2_MinGW_64_bit-Debug in D:\code\build-qtdeclarative-Desktop_Qt_6_2_2_MinGW_64_bit-Debug.
      CMake Warning at C:/Qt/Tools/QtCreator/share/qtcreator/package-manager/auto-setup.cmake:60 (message):
        Qt Creator: conan executable not found.  Package manager auto-setup will be
        skipped.  To disable this warning set QT_CREATOR_SKIP_CONAN_SETUP to ON.
      Call Stack (most recent call first):
        C:/Qt/Tools/QtCreator/share/qtcreator/package-manager/auto-setup.cmake:132 (qtc_auto_setup_conan)
        CMakeLists.txt:6 (project)
      -- Found OpenSSL: C:/Strawberry/c/lib/libcrypto.a (found version "1.1.1i")  
      -- Could NOT find Qt6ShaderTools (missing: Qt6ShaderTools_DIR)
      CMake Warning at C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6/Qt6Config.cmake:226 (message):
        Failed to find Qt component "ShaderTools".  Expected Config file at
        "C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6ShaderTools/Qt6ShaderToolsConfig.cmake"
        does NOT existCall Stack (most recent call first):
        CMakeLists.txt:45 (find_package)
      -- Check for feature set changes
      -- Tool 'Qt6::qmltyperegistrar' will be built from source.
      -- Could NOT find LTTngUST (missing: LTTNGUST_LIBRARIES LTTNGUST_INCLUDE_DIRS) 
      -- Using installed syncqt found at: C:/Qt/6.2.2/mingw_64/bin/syncqt.pl
      -- Running syncqt for module: 'QtQml' 
      -- Could NOT find LTTngUST (missing: LTTNGUST_LIBRARIES LTTNGUST_INCLUDE_DIRS) 
      -- Performing Test HAVE_DASH_UNDEFINED_SYMBOLS
      -- Performing Test HAVE_DASH_UNDEFINED_SYMBOLS - Success
      -- Performing Test HAVE_DASH_DASH_NO_UNDEFINED
      -- Performing Test HAVE_DASH_DASH_NO_UNDEFINED - Success
      -- Running syncqt for module: 'QtQmlModels' 
      -- Running syncqt for module: 'QtQmlCore' 
      -- Running syncqt for module: 'QtQmlWorkerScript' 
      -- Running syncqt for module: 'QtQmlLocalStorage' 
      -- Running syncqt for module: 'QtQmlXmlListModel' 
      -- Running syncqt for module: 'QtLabsSettings' 
      -- Running syncqt for module: 'QtLabsQmlModels' 
      -- Running syncqt for module: 'QtLabsFolderListModel' 
      -- Running syncqt for module: 'QtPacketProtocol' 
      -- Running syncqt for module: 'QtQmlDom' 
      -- Running syncqt for module: 'QtQmlCompiler' 
      -- Tool 'Qt6::qmlcachegen' will be built from source.
      -- Running syncqt for module: 'QtQmlDebug' 
      -- Tool 'Qt6::qmldom' will be built from source.
      -- Tool 'Qt6::qmllint' will be built from source.
      -- Tool 'Qt6::qmlimportscanner' will be built from source.
      -- Tool 'Qt6::qmlformat' will be built from source.
      -- Tool 'Qt6::qmlprofiler' will be built from source.
      -- The following packages have been found: * Qt6BuildInternals (required version >= 6.2.2)
       * Qt6CoreTools (required version >= 6.2.2)
       * Qt6Core (required version >= 6.2.2)
       * Qt6GuiTools (required version >= 6.2.2)
       * Qt6Gui (required version >= 6.2.2)
       * OpenSSL
       * WrapOpenSSLHeaders
       * Qt6Network (required version >= 6.2.2)
       * Qt6WidgetsTools (required version >= 6.2.2)
       * Qt6Widgets (required version >= 6.2.2)
       * Qt6OpenGL (required version >= 6.2.2)
       * Qt6OpenGLWidgets (required version >= 6.2.2)
       * Qt6Sql (required version >= 6.2.2)
       * Qt6Concurrent (required version >= 6.2.2)
       * Qt6Test (required version >= 6.2.2)
       * Qt6 (required version >= 6.2.2)
       * PythonInterp-- The following OPTIONAL packages have not been found: * PkgConfig
       * Vulkan
       * WrapVulkanHeaders
       * Qt6ShaderToolsTools (required version >= 6.2.2)
       * Qt6ShaderTools (required version >= 6.2.2)
       * LTTngUSTConfigure summary:Qt QML:
        QML network support .................... yes
        QML debugging and profiling support .... yes
        QML just-in-time compiler .............. yes
        QML sequence object .................... yes
        QML XML http request ................... yes
        QML Locale ............................. yes
      Qt QML Models:
        QML list model ......................... yes
        QML delegate model ..................... yes
      Qt Quick:
        Qt Quick support ....................... noNote: Qt Quick modules not built due to not finding the qtshadertools 'qsb' tool.ERROR: Python is required to build QtQml.CMake Error at C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6/QtBuildInformation.cmake:80 (message):
        Check the configuration messages for an error that has occurred.
      Call Stack (most recent call first):
        C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6/QtBuildInformation.cmake:11 (qt_configure_print_summary)
        C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6BuildInternals/Qt6BuildInternalsConfig.cmake:472 (qt_print_feature_summary)
        C:/Qt/6.2.2/mingw_64/lib/cmake/Qt6BuildInternals/Qt6BuildInternalsConfig.cmake:491 (qt_build_repo_end)
        CMakeLists.txt:63 (qt_build_repo)
      -- Configuring incomplete, errors occurred!
      See also "D:/code/build-qtdeclarative-Desktop_Qt_6_2_2_MinGW_64_bit-Debug/CMakeFiles/CMakeOutput.log".
      See also "D:/code/build-qtdeclarative-Desktop_Qt_6_2_2_MinGW_64_bit-Debug/CMakeFiles/CMakeError.log".
      CMake process exited with exit code 1.Elapsed time: 00:05.
      

      There's only one error:

      ERROR: Python is required to build QtQml

      That can't be right. Or there are specific python details it misses and doesn't tell me about.  My `python --version` output in cmd:

      C:\Users\mark>python --version
      Python 3.9.9
      

      Trying to debug further in the CMakeError.log doesn't tell me that much other then the ninja.exe command failed. I'll attach that file.

      Any clue what the actual error is and how to fix it?

      only want to recompile QtDeclarative because i want to make a patch to fix some SpinBox nightmares i have. I do not want to recompile all of Qt.

        Attachments

        1. build_log_2.7z
          125 kB
        2. build_log_3.7z
          125 kB
        3. build_log.7z
          972 kB
        4. cmake_output.PNG
          cmake_output.PNG
          112 kB
        5. CMakeCache.txt
          61 kB
        6. CMakeError.log
          2 kB
        7. no_vulkan.PNG
          no_vulkan.PNG
          40 kB
        8. phton_is_there.PNG
          phton_is_there.PNG
          322 kB
        9. QtDeclarativeSetup.cmake
          2 kB
        10. Screenshot 2021-12-16 at 19.29.54.png
          Screenshot 2021-12-16 at 19.29.54.png
          407 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            alexandru.croitor Alexandru Croitor
            Reporter:
            markg85 Mark
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes