Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99411

[REG 5.15->6.2] Rendering aftifacts on windows with nvidia driver

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 6.2.2, 6.3
    • Fix Version/s: None
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Windows 11
      Nvidia driver
    • Platform/s:
      Windows

      Description

      Most easily reproducible with recipebrowser (quick) but also visible with simplebrowser (widget) on various sites (including qt.io). See attached screenshots. Resizing the window helps to reproduce.

      --disable-gpu-compositing or enabling software rendering works fine. 5.15 works fine. Debug build works fine, only reproducible in release. No error message in console (apart from Vulkan disabled or failed to initialize).

      I could only reproduce this on Windows 11 with Nvidia driver. Windows 10 with Intel works just fine.

      The OpenGL context log is:

      GLImplementation: desktop
      Surface Type: OpenGL
      Surface Profile: CompatibilityProfile
      Surface Version: 4.6
      Using Default SG Backend: yes
      Using Software Dynamic GL: no
      Using Angle: no
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt_webengine_team Qt WebEngine Team
            Reporter:
            pvarga Peter Varga
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes