Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99427

[REG:5.15.6->5.15.7]: Qt 5.15 can no longer be build with C++11

    XMLWordPrintable

    Details

    • Commits:
      b982e62d19 (qt/tqtc-qtbase/5.15)

      Description

      Culprit commit https://codereview.qt-project.org/c/qt/tqtc-qtbase/+/363053 adds usage of std::exchange which is introduced in c++14, breaking c++11 build.

      README states that 5.15 should be buildable with c++11 compiler.

        Attachments

        For Gerrit Dashboard: QTBUG-99427
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            mmutz Marc Mutz
            Reporter:
            jussi_witick Jussi Witick
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes