Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99473

QtWebEngine displays color banding on Wayland with QT_WAYLAND_DISABLE_WINDOWDECORATION=1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Incomplete
    • Affects Version/s: 5.15.3, 6.2.2
    • Fix Version/s: None
    • Component/s: QPA: Wayland, WebEngine
    • Labels:
      None
    • Environment:
      Linux (NixOS 22.05), Sway
    • Platform/s:
      Linux/Wayland

      Description

      QtWebEngine-based browsers (this issue was originally discovered in Qutebrowser - related ticket 1, related ticket 2) seem to experience weird color banding when having the variable `QT_WAYLAND_DISABLE_WINDOWDECORATION` set to `1`. This doesn't seem to happen when window decorations are suppressed through the Wayland compositor, such as Sway.

      This issue was deemed an upstream bug and as such I am reporting it here. Please note that this is my first time working with the Qt bugtracker or reporting bugs to Qt and as such do not hesitate to reach out for more information in comments.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt.team.graphics.and.multimedia Qt Graphics Team
            Reporter:
            vikanezrimaya Vika Shleina
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes