Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99580

QtWebEngine form select field popups on Wayland do not accept touch events (PinePhone)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.15.7
    • Fix Version/s: None
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
    • Platform/s:
      Linux/Wayland

      Description

      On my PinePhone (i.e., a touch device) running Manjaro Plasma Mobile (i.e., a KWin-Wayland environment), if I open a web page containing a form with a select (dropdown) input field in Angelfish (which uses QtWebEngine), I am unable to select an option from the dropdown: the dropdown opens correctly, but the resulting popup does not respond to finger touches. Instead, the touch closes the popup without selecting an item and the click goes through to whatever sits below the popup.

      A public site where you can test the behavior is: https://www.falter.at/lokalfuehrer :

      1. make sure you are on a touch device using KWin-Wayland (e.g., a PinePhone running Plasma Mobile) - the bug is not reproducible with a mouse nor under X11,
      2. click through the cookie preferences, they are not the problem,
      3. click on "⌄ SUCHFILTER ÄNDERN" (change search filters) - that is needed to uncover the form,
      4. click on "ALLE BUNDESLÄNDER ▾" (all federal states (of Austria)) - the actual popup,
      5. try to select one of the 9 states, any one (if in doubt, pick "WIEN" (Vienna)), with a finger.
      • Expected result: the state (e.g., WIEN) gets selected.
      • Actual result: the click goes through to whatever is on the site below the state, either doing nothing or triggering a misclick. The state selection is still stuck on "ALLE BUNDESLÄNDER" (all states).

      Available workarounds:

      • plug in the USB dock and a USB mouse (or, I suppose, a USB C mouse directly), and use the mouse to click (works, but not very practical on the move) or
      • force using xcb and XWayland: QT_QPA_PLATFORM=xcb angelfish - though then the virtual keyboard does not work, so text fields can only be filled in a contrived way using the clipboard (at least, clipboard sync between XWayland and native Wayland now works, but still, it is a pain).

      This is similar behavior to this GTK bug on the same environment: https://gitlab.gnome.org/GNOME/gtk/-/issues/3737 . However, as I understand it, QtWebEngine does not use GTK (or does it?). A bug was also filed against plasma-phone-components: https://invent.kde.org/plasma/plasma-phone-components/-/issues/65 but they currently tend towards blaming it on GTK (and presumably, QtWebEngine as well).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qt_webengine_team Qt WebEngine Team
            Reporter:
            kevin kofler Kevin Kofler
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes