Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-99633

[autotests] tst_QIcoImageFormat should be behind a feature flag

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 6.2.2
    • Fix Version/s: 6.3.0 Alpha
    • Component/s: Core: Plugins
    • Labels:
      None
    • Platform/s:
      webOS
    • Commits:
      a4783abc60 (qt/qtbase/6.3)

      Description

      When "ico" feature is configured off, libqico.so is not built, but its tests are still run and fail (at least on webOS). 

      src/gui/configure.cmake:

      qt_feature("ico" PUBLIC PRIVATE
      LABEL "ICO"
      CONDITION QT_FEATURE_imageformatplugin
      )

      src/plugins/imageformats/CMakeLists.txt:

      if(QT_FEATURE_ico)
      add_subdirectory(ico)
      endif()

      /tests/auto/gui/image/CMakeLists.txt: 

      add_subdirectory(qicoimageformat)

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            jannej Janne Juntunen
            Reporter:
            jannej Janne Juntunen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes