Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-20409

A kit's custom environment messes up the build environment

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: Qt Creator 4.5.2
    • Fix Version/s: Qt Creator 4.6.0
    • Labels:
    • Environment:
      Windows 7 64bit

      Visual C++ 2015 64bit

      Qt 5.9.5 (via the official installer)
    • Commits:
      ab9cce7fe7adba200744c5930600d3d1c43a9073

      Description

      After inserting a custom environment for my preferred kit, e.g.

      INCLUDE=D:\Development9\UnixLibsV9-x64\include;${INCLUDE}
      LIB=D:\Development9\UnixLibsV9-x64\lib;${LIB}
      PATH=D:\Development9\UnixLibsV9-x64\bin;${PATH}

      , the Qt Creator is unable to build my C++ project and complains about missing cl.exe or nmake.exe (depending on the state the project is in).

      Since I am using the official installers for Windows, I know that inserting a custom environment worked fine with the Creator of the 5.6.1 installer. The Creator of the 5.9.5 installer messes things up.

      I need to use some custom build Unix libraries in several projects I am developing, so it is a lot easier for me to put them in a custom environment than to add them into each .PRO file.

      Please fix this for the next official installer!

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              hunger Tobias Hunger
              Reporter:
              omarhawk Carsten Schmidt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes