Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-20414

Run executable empty

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Duplicate
    • Affects Version/s: Qt Creator 4.6.1
    • Fix Version/s: None
    • Labels:
    • Environment:
      macOS 10.12.5
      XCode 8.3.3
      Creator 4.6.1
      Qt 5.11.0 rc from online installer

      Description

      I'm testing the online installer Qt 5.11.0 rc package.
      I'm using the Qt Creator included with that package.

      I open the official_qt511/Examples/Qt-5.11.0/sensors/sensor_explorer/sensor_explorer.pro project with the autodetected kit .

      Project parsing succeeds, but if I go to the Run tab of the project, Executable is empty, and trying to run prints "No executable specified.".

      Switching to other kits that I have, seems to work. Both for official kits, and custom built ones.

      Building and running projects like qtmultimedia/multimedia/declarative-camera and webengine/simplebrowser works.

      It looks like it might be related to the fact that the sensor example is a subdirs project?

      I'm not sure if this is a Qt Creator issue, specific Creator installed from online installer issue, Qt 5.11.0 rc issue or some combo.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                hunger Tobias Hunger
                Reporter:
                alexandru.croitor Alexandru Croitor
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes