Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-20696

QmlJSEditor: Wrong error on module import

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: Qt Creator 4.7.0-beta2
    • Fix Version/s: None
    • Component/s: Quick / QML Support
    • Labels:
    • Platform/s:
      Linux/X11

      Description

      Steps to reproduce:

      • have Qt5.11 installed and configured as kit (I've got 5.11.0 official release if that matters)
      • create an application from template (Qt Quick Application - Empty)
        • ensure setting minimum required Qt to 5.11

      Current result:

      • QC marks the line
      import QtQuick.Window 2.11

      with an error and "QML module not found (QtQuick.Window)."

       

        Attachments

        For Gerrit Dashboard: QTCREATORBUG-20696
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            mabenell Marco Benelli
            Reporter:
            cstenger Christian Stenger
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes