Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-21780

infinite loop recursion in Android::Internal::AndroidToolChain::detectSupportedAbis

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: Qt Creator 4.8.0
    • Fix Version/s: Qt Creator 4.8.1
    • Component/s: Android Support
    • Labels:
      None

      Description

      The 4.8.0 packaged version from the online installer has been crashing for me on Ubuntu 18.04; I just got around to running it in gdb to see what goes wrong:

      Thread 1 "qtcreator" received signal SIGSEGV, Segmentation fault.
      0x00007fffcc070d05 in Android::Internal::AndroidToolChain::detectSupportedAbis() const () from /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
      (gdb) bt
      #0  0x00007fffcc070d05 in Android::Internal::AndroidToolChain::detectSupportedAbis() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
      #1  0x00007fffce84f955 in ProjectExplorer::GccToolChain::originalTargetTriple() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libProjectExplorer.so
      #2  0x00007fffcc070d21 in Android::Internal::AndroidToolChain::detectSupportedAbis() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
      #3  0x00007fffce84f955 in ProjectExplorer::GccToolChain::originalTargetTriple() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libProjectExplorer.so
      #4  0x00007fffcc070d21 in Android::Internal::AndroidToolChain::detectSupportedAbis() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
      #5  0x00007fffce84f955 in ProjectExplorer::GccToolChain::originalTargetTriple() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libProjectExplorer.so
      #6  0x00007fffcc070d21 in Android::Internal::AndroidToolChain::detectSupportedAbis() const () at /home/rutledge/Qt/Tools/QtCreator/lib/qtcreator/plugins/libAndroid.so
      

      I wouldn't be surprised if there's some configuration problem, but I haven't yet tried deleting all the config files. I keep running the Creator 4.5.2 that ships with Ubuntu as a backup for now.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                vikas Vikas Pachdha
                Reporter:
                srutledg Shawn Rutledge
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes