Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-22108

'cannot open input file 'Core4.lib'' errors for building qtcreator plugin on Windows. I think if Core4.lib was included in the QtCreator installation then plugin development could have been easier!

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Invalid
    • Affects Version/s: Qt Creator 4.8.2, Qt Creator 4.9.0-beta1
    • Fix Version/s: None
    • Component/s: Building Qt Creator
    • Labels:
      None
    • Platform/s:
      Windows

      Description

      The prebuild QtCreator should include Core4.lib as it would avoid the user to compile his/her own version of QtCreator for building plugins for QtCreator.

      Right now when I build a hello world plugin for QtCreator the gives me the following error:

      :-1: error: LNK1181: cannot open input file 'Core4.lib'

      I think if Core4.lib was included in the QtCreator installation then plugin development could have been easier!

      Right now I am forced to build my own version of QtCreator

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              con Eike Ziller
              Reporter:
              eager1 Shujaat Khan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes