Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-23335

CMAKE_AR/NM/RANLIB/LINKER/OBJDUMP/OBJCOPY are not set correctly.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Invalid
    • Affects Version/s: Qt Creator 4.11.0-rc1
    • Fix Version/s: None
    • Labels:
      None

      Description

      I'm using cmake 3.15 on my debian or I can use the one from the sdk, which is 3.15.3.

      Given that I'm cross-compiling and using this toolchain file:

      https://github.com/openembedded/openembedded-core/blob/master/meta/recipes-devtools/cmake/cmake/OEToolchainConfig.cmake

      For some reason when I go to

      • Projects tab.
      • Select my cross-compiling kit
      • Select Build
      • Click Advanced
      • Look at CMAKE_AR/NM/RANLIB/LINKER/...
      • The path that it's using is the `target` one so for me it's an aarch64 binary.

      If I print a message inside my top-level CMakeLists.txt

      message(FATAL_ERROR ${CMAKE_AR})
      

      The one from the x86_64 SDK is printed (The correct one). So my question is, why there is a difference between what I print from the CMake file and what QtCreator thinks the path is.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              hunger Tobias Hunger
              Reporter:
              roussinm Maxime Roussin-BĂ©langer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes