Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-24561

Qt Creator depends on xcb libraries that are not necessarily installed by default

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Duplicate
    • Affects Version/s: Qt Creator 4.13.0
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      Ubuntu 18.04.5 LTS
      Virtualization: Microsoft Hyper-V
    • Platform/s:
      Linux/X11

      Description

      If I start Qt Creator with the console I get the following output:

       

      qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
      This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
      Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
      Aborted (core dumped)
      

      I have reinstalled Qt, but this didn't helped.

       

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              con Eike Ziller
              Reporter:
              autoantwort autoantwort
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes