Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-24632

Debugging not working with root-level symbolic links on macOS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: Not Evaluated
    • Resolution: Unresolved
    • Affects Version/s: Qt Creator 4.13.0
    • Fix Version/s: None
    • Component/s: Debugger
    • Labels:
      None
    • Environment:
      macOS Catalina 10.15.6
    • Platform/s:
      macOS

      Description

      The debugger does not hit breakpoints when the build directory contains a folder created with a root-level symbolic link. This was still working in Qt Creator 4.12.

      Details: For conformance with my Windows development environment I had to create a root-level symbolic link adding the following entry in /etc/synthetic.conf (as required by macOS Catalina to create rool-level directories):

      Q       /Users/dominik/Q

      In my Qt project the debug build directory is set as

      /Q/Build/App_Debug

      When running in debug mode the application does not stop at breakpoints. Instead I need to eliminate the link by changing the build directory to

      /Users/dominik/Q/Build/App_Debug

      After rebuild breakpoints are working again.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            hjk hjk
            Reporter:
            ornello Dominik Hörnel
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes