Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-24844

Preferred build target is lost after running CMake

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Duplicate
    • Affects Version/s: Qt Creator 4.13.2
    • Fix Version/s: None
    • Component/s: C/C++/Obj-C++ Support
    • Labels:
      None
    • Platform/s:
      Linux/X11

      Description

      I am using Qt creator with a large project with many executable build targets.

      Under Projects -> Build & Run -> Build Settings -> Build Steps I select "<Current executable>" as the target to be added to CMake arguments.  This setting is used for the subsequent builds, but gets reset to "all" after running CMake, regardless whether I run CMake manually or CMake is run automatically at startup.

      This seems to be a regression, as the build target used to persist in the settings until changed manually.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kandeler Christian Kandeler
              Reporter:
              strahinjalukic Strahinja Lukic
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes