Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-24910

Can not launch applications on iOS hw via Creator

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P0: Blocker
    • Resolution: Duplicate
    • Affects Version/s: Qt Creator 4.13.3
    • Fix Version/s: None
    • Component/s: iOS Support
    • Labels:
    • Environment:
      macOS10.15
      xcode 12.1
      iPadOS 14.1
    • Platform/s:
      iOS/tvOS/watchOS

      Description

      Install Qt5.15.2 iOS binaries from staging repo, finish installation and launch QtCreator 4.13.3. Select any of the examples, build and deploy to device.

      Build is successful and application is deployed, but it doesn't launch even if the green triangle is clicked again (debug and release has same output). Output in Application Output view:

      14:56:28: Starting remote process. TransferAppSession(52e7b9b9ca560443a9ed95677533042f72f26729, /Users/qt/Qt_515/Examples/Qt-5.15.2/widgets/graphicsview/build-chip-Qt_5_15_2_for_iOS-Release/Release-iphoneos/chip.app)Starting(Secure) service "com.apple.debugserver" on device 52e7b9b9ca560443a9ed95677533042f72f26729 failed, AMDeviceStartSecureService returned The service is invalid. (0xe8000022)no gdb connection14:56:28: Run ended.
      

      If the app is tapped from device screen it will launch normally.

      Also if the project is opened in xcode (with the .xcodeproject file generated by Creator) and deployed, it will launch on device automatically.

      If switching to iOS Simulator build, build and deploy -> application is launched in simulator.

      Using 5.15.1 iOS binaries isn't much better, it fails also but with different error:

      ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.1.sdk/usr/lib/libc++.tbd, missing required architecture x86_64 in file /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.1.sdk/usr/lib/libc++.tbd (4 slices) ld: building for iOS, but linking in object file built for iOS Simulator, file '/var/folders/fk/4g4xbvys68j1wyxg75gzkhcr0000gp/T/--d57917.o' for architecture x86_64clang: error: linker command failed with exit code 1 (use -v to see invocation)===================Maybe you forgot to setup the environment?15:11:10: The process "/Users/qt/Qt_515/5.15.1/ios/bin/qmake" exited with code 3.Error while building/deploying project chip (kit: Qt 5.15.1 for iOS)The kit Qt 5.15.1 for iOS has configuration issues which might be the root cause for this problem.When executing step "qmake"
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              vikas Vikas Pachdha
              Reporter:
              joaijala Johanna Äijälä
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes