Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-25912

Debugger not showing attribute values

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: Not Evaluated
    • Resolution: Unresolved
    • Affects Version/s: Qt Creator 4.14.0
    • Fix Version/s: None
    • Component/s: Debugger
    • Labels:
      None
    • Environment:
      Qt 5.15.2 (but reproducable on lots of other versions of Qt and QtCreator)
      CDB.EXE 10.0.17763.132 (but other versions have the same problem)
      Windows 10
    • Platform/s:
      Windows

      Description

      The problem is when I enter a function by single step the right panel that shows the current status of the values is blank, however when I go into some other function it then reappears and I'm able to see the variables and its values/contents. Also when I mouse hover over a variable there is nothing there and I get a tool tip "Expression to Complex" . 

      This problem is intermittent and has been occuring to everyone on our team for sometime now.  Sometimes, stepping through a method, values will be shown and then on a next step will disappear. Adding code in unrelated locations on the file can cause this problem to get better or worse.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            davschul David Schulz
            Reporter:
            mark02482 Mark Antonelli
            Votes:
            5 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes