Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-26193

Bold and italic are ignored on theme by language client

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: Not Evaluated
    • Resolution: Unresolved
    • Affects Version/s: Qt Creator 5.0.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Gentoo
      kernel 5.10.61
    • Platform/s:
      Linux/X11

      Description

      Edit: what appears to be happening is that when language server client provides a token, but qtcreator doesn't have that token associated to creator highlighting type(such as C_KEYWORD), default text bold/italic qualifiers stick to the token. And then colour is still applied normally. Types are applied at languageclient/semantichighlightsupport.cpp:302

       

      For some reason only font and colour are applied to tokens processed by language client highlighter(recently added). Bold and italic qualifiers are just ignored. As you can see i have types as bold purple in my theme, and indeed Kate highlighting applies properly in bold, but symbols parsed by rust-analyzer are not bold. For example u32 is a primitive type and not marked for highlighting, while f16 and Vec are actual types.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            davschul David Schulz
            Reporter:
            anomalocaris Alex Drozdov
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes