Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-26863

Default build directory setting is ignored

    XMLWordPrintable

    Details

    • Platform/s:
      Linux/X11

      Description

      In both QtCreator 4 and 5 I used 

      %{Env:CURRENT_CMAKE_BUILD_DIR}/%{Project:Name}
      

      as default build directory in Build & Run -> Default Build Properties.

      When opening a CMakelists.txt, it would then automatically check for a build to be imported in the configure project view.

      Now it doesn't do that. The Import Build From... section is collapsed. When I expand it, the directory is set to the Projects Directory value.

      I changed the Default Build Directory to

      %{Env:CURRENT_CMAKE_BUILD_DIR}/%{ActiveProject:Name}
      

      As I think Project:Name is not supported anymore in QtCreator6. Still it doesn't work.

      When following the same steps to open a project as described above, I replace the Projects Directory value with the new value using ActiveProject:Name
      and browse, it opens nautilus in the correct folder. So the resolving of the variables works fine.

      Please restore the old behaviour.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            davschul David Schulz
            Reporter:
            matthijsburgh Matthijs van der Burgh
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes