Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-27103

Android deployment fails if the kit ABI is not known for some reason

    XMLWordPrintable

Details

    • c1512dce87 (qt-creator/qt-creator/7.0) c1512dce87 (qt-creator/qt-creator/master) c1512dce87 (qt-creator/tqtc-qt-creator/7.0) c1512dce87 (qt-creator/tqtc-qt-creator/master) c1512dce87 (qt-creator/tqtc-qt-creator/qds-3.1)

    Description

      The deployment might fail sometimes if the kit's ABIs list is not known:

      The kit supports "", but the device uses "arm64-v8a, armeabi-v7a, armeabi".

      This probably underlines a deeper issue because the kit's ABIs list should be valid if the kit is valid. However, it might be reasonable to go forward with the deployment if this case is hit and fail later to install if the ABIs don't match.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          People

            assam Assam Boudjelthia
            assam Assam Boudjelthia
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes