Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-27285

Test runner remains in "Running" mode if the test runner binary doesn't exist

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • P1: Critical
    • Resolution: Done
    • Qt Creator 7.0.0
    • Qt Creator 7.0.1
    • Test Integration
    • None
    • Linux/X11
    • 17ef9bc35c (qt-creator/qt-creator/7.0) 17ef9bc35c (qt-creator/qt-creator/master) 17ef9bc35c (qt-creator/qt-creator/qds-3.3) 17ef9bc35c (qt-creator/tqtc-qt-creator/7.0)

    Description

      I have a project which has a Boot.Test test runner. If the test runner target is built, tests run just fine. However, if I clean the project so that test runner binary doesn't exists, and then try Run Selected Tests (or Run All Tests); QtCreator goes into "Running Tests" state. It prints "Failed to start test for project ...", but it remains in Running Tests mode. Even if I press the Stop button, it prints "Test run canceled by user", but it is still in "Running Tests" mode. Till now, the only way out of this state for me is to close and re-open QtCreator. Otherwise I can no longer run tests.

      Attachments

        For Gerrit Dashboard: QTCREATORBUG-27285
        # Subject Branch Project Status CR V

        Activity

          People

            cstenger Christian Stenger
            hedayat Hedayat Vatankhah
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes