Uploaded image for project: 'Qt Installer Framework'
  1. Qt Installer Framework
  2. QTIFW-1551

Qt IFW for macOS is configured with OpenSSL and not SecureTransport

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P1: Critical
    • Resolution: Unresolved
    • Affects Version/s: 3.2.0
    • Fix Version/s: None
    • Component/s: General
    • Platform/s:
      macOS

      Description

      Qt IFW for macOS is configured with OpenSSL and not SecureTransport, as a result this is causing a problem in some cases where it is unable to connect to a https server. Since SecureTransport is the default on macOS now then it should be built using that instead of using OpenSSL.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              installerteam Installer Team
              Reporter:
              andysh Andy Shaw
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Gerrit Reviews

                There are no open Gerrit changes