Uploaded image for project: 'Qt Installer Framework'
  1. Qt Installer Framework
  2. QTIFW-2250

CLI: MaintenanceTool install should succeed if packages already installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Out of scope
    • Affects Version/s: 4.1.0
    • Fix Version/s: None
    • Component/s: CLI
    • Platform/s:
      All

      Description

      When calling `MaintenanceTool install` with packages that are already installed, the installer prints "Components already installed." and returns a non-zero exit code (3).
      When installing Qt e.g. using provisioning scripting, this cannot be told from an actual error in a robust way, as they also return with exit code 3.

      I think `MaintenanceTool install` should return 0 when all packages are already installed, which would be the standard behavior from other package managers (apt, yum, brew, chocolatey, you name it).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            installerteam Installer Team
            Reporter:
            frank.osterfeld Frank Osterfeld
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes