Uploaded image for project: 'Qt Installer Framework'
  1. Qt Installer Framework
  2. QTIFW-2486

MaintenanceTool does not work if started as root

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Fixed
    • Affects Version/s: 4.2.0, 4.3.0
    • Fix Version/s: 4.3.0
    • Component/s: General
    • Platform/s:
      Linux/X11
    • Sprint:
      Qt Installer Sprint 48

      Description

      Starting the maintenance tool with su/sudo yields:

      [14] Warning: Failure to read packages from /opt/Qt/components.xml.
      [14] Critical: Operations missing for installed packages ()
      [14] Critical: Orphaned operations ("qt", "qt.tools.ninja", "qt.tools", "qt.tools.qtcreator", "qt.tools.maintenance", "qt.tools.cmake")
      [15] Critical: Your installation seems to be corrupted. Please consider re-installing from scratch, remove the packages from components.xml which operations are missing, or reinstall the packages.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            arttu.tarkiainen Arttu Tarkiainen
            Reporter:
            arttu.tarkiainen Arttu Tarkiainen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes