Uploaded image for project: 'Qt Quality Assurance Infrastructure'
  1. Qt Quality Assurance Infrastructure
  2. QTQAINFRA-2780

Qt 5.12 will not run on openSUSE 42.3

    XMLWordPrintable

    Details

    • Platform/s:
      Linux/X11
    • Technical Risk:
      Normal

      Description

      With Qt 5.12 came a few problems for some of our customers. It seems like 5.12 binaries supplied by TQC has some problems with some of the libraries (libdbus), and requires newer versions than what's available in openSUSE 42.3.

      OpenSUSE 42.3 is listed as supported on our page: http://doc.qt.io/qt-5/linux.html, so we need to update this according to our actual testing and build.

       

      Suggested Workarounds:

      1. With https://codereview.qt-project.org/#/c/255622/ one can update the openSUSE's dbus libraries so that our RHEL binaries work on it
      2. Build Qt on openSUSE 42.3, which will include the correct version of libdbus in the build

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              hakjol Harald Kjølberg (Inactive)
              Reporter:
              hakjol Harald Kjølberg (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes