Uploaded image for project: 'Qt Quality Assurance Infrastructure'
  1. Qt Quality Assurance Infrastructure
  2. QTQAINFRA-3271

Update qt5.git wip/cmake to provision Python 3.7 on macOS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: production
    • Fix Version/s: None
    • Labels:
      None
    • Platform/s:
      macOS
    • Commits:
      ecf2f4f38cde8983bb357f6241478ac3170ac9ac

      Description

      Hi,

      In order to integrate some variation of https://codereview.qt-project.org/c/qt/qtbase/+/276476 I need a Python 3.7+ installed on macOS.

      Currently we provision 3.6 as can be seen here https://code.qt.io/cgit/qt/qt5.git/tree/coin/provisioning/common/macos/python3.sh?h=wip/cmake#n46 and it seems a 3.7 installer from python.org needs to be uploaded to some internal server.

      Would someone be able to upload and update the provisioning script just for macOS in wip/cmake branch?

        Attachments

        For Gerrit Dashboard: QTQAINFRA-3271
        # Subject Branch Project Status CR V

          Activity

            People

            • Assignee:
              liaqi Liang Qi
              Reporter:
              alexandru.croitor Alexandru Croitor
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes