Uploaded image for project: 'Qt Quality Assurance Infrastructure'
  1. Qt Quality Assurance Infrastructure
  2. QTQAINFRA-3279

Provisioning on Ubuntu 18.04 fails - upstream repos are messed up, need local mirrors of everything

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • P1: Critical
    • Resolution: Done
    • unversioned
    • None

    Description

      Running integration for qt 5.13, fails while provisioning Ubuntu 18.04:

      + sudo apt-get install docker-ce -y
      Reading package lists...
      Building dependency tree...
      Reading state information...
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
       docker-ce : Depends: containerd.io (>= 1.2.2-3) but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      

      https://testresults.qt.io/coin/api/results/provisioning/qtci-linux-Ubuntu-18.04-x86_64-b03fff/provision_1570885476/log.txt.gz

      EDIT: See epic QTQAINFRA-3395 for fixing the remaining external dependencies of our provisioning scripts.

      TODO

      • DONE download the docker RPM/DEB packages and install them directly, without using repositories

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              jimis Dimitrios Apostolou
              jimis Dimitrios Apostolou
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: