Uploaded image for project: 'Qt Quality Assurance Infrastructure'
  1. Qt Quality Assurance Infrastructure
  2. QTQAINFRA-4057

Need newer node.js on Ubuntu 18.04 for WebEngine 5.15.3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.15
    • Fix Version/s: None
    • Labels:
      None

      Description

      QtWebEngine 5.15.3 is scheduled for its final update of Chromium to be based on Chrome 87. This versions makes node.js mandatory for building the devtools, and we haven't found a way to make it optional again. 

      Also it appears the node.js version 8.10 installed on Ubuntu 18.04 doesn't compile correctly. Though it is inconsistent, see http://coin.intra.qt.io/coin/integration/qt/qtwebengine/tasks/web_qt_qtwebengine_1607619254030 with some platforms managing to build but not link, while others seem to not be able to parse "async import".

       

      I believe the simplest solution would be to use a more modern node.js version, either by downloading and installing official packages like we do for Windows, or by using a PPA like https://deb.nodesource.com/node_14.x/.

       

      Note SLES also is missing node.js, and at least downloading packages could also work for it.

        Attachments

        For Gerrit Dashboard: QTQAINFRA-4057
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            hehalmet Heikki Halmet
            Reporter:
            allan.jensen Allan Sandfeld Jensen
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes