Uploaded image for project: 'Qt Visual Studio Tools'
  1. Qt Visual Studio Tools
  2. QTVSADDINBUG-570

Version 2.2.2 specifies 2.2.1 in its manifest, hence does not install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.2.2
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      Microsoft Visual Studio 2013/2015
    • Platform/s:
      Windows
    • Commits:
      6f7fb6a66c80746a56844e727e9f422455029037

      Description

      Qt Visual Studio Tools 2.2.2 for VS 2015 (MD5: ED9F989063E817B01E19EF144C43AB5E) has the following identity in its extension.vsixmanifest file:

      <Identity Id="QtVsTools.30112013-cd02-4fd0-89bd-e36f85abe16a" Version="2.2.1" Language="en-US" Publisher="The Qt Company Ltd." />

      (likewise, Qt Visual Studio Tools 2.2.2 for VS 2013, MD5: FF97D5A835B3B25B666B1436B5475F8F). Therefore, when I try to install any of them, I get just

      ---------------------------
      VSIX Installer
      ---------------------------
      This extension is already installed to all applicable products.
      ---------------------------
      OK   
      ---------------------------
      

      Note: Qt Visual Studio Tools 2.2.2 for VS 2017 (MD5: 1A4912F515D6C7775063337EC446AEDE) has correct version in its manifest files.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            mecfc Miguel Costa
            Reporter:
            hart Khamidullin, Ruslan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes