Uploaded image for project: 'Qt Visual Studio Tools'
  1. Qt Visual Studio Tools
  2. QTVSADDINBUG-804

Plugin Bug moc: Missing value after '-D'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Need More Info
    • Priority: Not Evaluated
    • Resolution: Incomplete
    • Affects Version/s: 2.5.1 (rev.08), 2.5.1 (rev.18), 2.5.2
    • Fix Version/s: None
    • Component/s: Qt/MSBuild
    • Labels:
      None
    • Environment:
      Tested on several Windows 10 Pro PCs with Visual Studio 2015 Enterprise and QT 5.14.1. If "Automatic Update Extensions" is activated, the error appears. I have to install the older plugin 2.5.1 to get it work.
    • Platform/s:
      Windows

      Description

      Version 2.5.1 is the last working for me. With a newer version of the plugin i get the following moc errors:

      > Reading Qt configuration (C:\Qt\Qt5.14.1\5.14.1\msvc2017\bin\qmake.exe)
      > uic WhWebView.ui
      > moc qtwinmigrate\qwinwidget.h
      > moc qtwinmigrate\qwinhost.h
      > moc WebPage.h
      > moc WebUrlRequestInterceptor.h
      > moc WhWebView.h
      > moc: Missing value after '-D'.
      > moc: Missing value after '-D'.
      > moc: Missing value after '-D'.
      > moc: Missing value after '-D'.
      > moc: Missing value after '-D'.
      >qtwinmigrate\qwinwidget.h : error 1: moc (C:\Qt\Qt5.14.1\5.14.1\msvc2017\bin\moc.exe)

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            mecfc Miguel Costa
            Reporter:
            jenslu Jens Lukowski
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes