Uploaded image for project: 'Qt Design Studio'
  1. Qt Design Studio
  2. QDS-5803

Imported translations not working

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Won't Do
    • Affects Version/s: QDS 2.3 Beta
    • Fix Version/s: None
    • Labels:
      None
    • Platform/s:
      Windows
    • Sprint:
      QDS Berlin- 2022 Week 05/06

      Description

      I have imported translations from a JSON files, the translations show correctly in the Translations View.

      Translations do not show up in the UI.

      When I run QML translation test it stops with this error message:

      During the test, I can see the English translations in the correct place in the UI so it can read those correctly at least.

      This is the generated JSON report:

      {
          "components": [
              {
                  "componentPath": "",
                  "errors": [
                  ]
              }
          ]
      }
      
      

      When I try to generate .qm and .ts files, I get:

      :-1: error: Dropped 1 message(s) which had no ID.
      :-1: error: Dropped 1 message(s) which had no ID.
      

      Attached you find the QDS project and the JSON file I have imported translations from.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            tupelkon Tuomo Pelkonen
            Reporter:
            mahonkam Mats Honkamaa
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes