Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-102127

Can't build qttools/6.2.3@qt/everywhere on ubuntu

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 6.2.3
    • Fix Version/s: None
    • Component/s: Build System: CMake, Conan
    • Labels:
      None
    • Platform/s:
      Linux/X11

      Description

      I have added conan qt repository and trying to build a recipe, but it fails:

      conan install qttools/6.2.3@qt/everywhere --build missing 

      I have added conan qt repository and trying to build a recipe, but it fails:

      conan install qttools/6.2.3@qt/everywhere --build missing 

       

       

      Configuration:Configuration:[settings]
      arch=x86_64
      arch_build=x86_64
      build_type=RelWithDebInfo
      compiler=gcc
      compiler.cppstd=17
      compiler.libcxx=libstdc++11
      compiler.version=11.2
      os=Linuxos_build=Linux
      "qtbase":build_type=RelWithDebInfo
      [options]
      *:with_ffmpeg=False
      vulkan-loader:shared=True
      [build_requires]
      [env]
      WARN: qtactiveqt/6.2.3@qt/everywhere: requirement qtbase/[<=6.2.3, include_prerelease=True]@qt/everywhere overridden by qttools/6.2.3@qt/everywhere to qtbase/6.2.3@qt/everywhere QtOptionParser: load configure options ..QtOptionParser: reading Qt configure options from: /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/export/configure_options.jsonQtOptionParser: reading Qt configure features from: /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/export/configure_features.txtWARN: qtdeclarative/6.2.3@qt/everywhere: requirement qtbase/[<=6.2.3, include_prerelease=True]@qt/everywhere overridden by qttools/6.2.3@qt/everywhere to qtbase/6.2.3@qt/everywhere WARN: qtimageformats/6.2.3@qt/everywhere: requirement qtbase/[<=6.2.3, include_prerelease=True]@qt/everywhere overridden by qtdeclarative/6.2.3@qt/everywhere to qtbase/6.2.3@qt/everywhere WARN: qtshadertools/6.2.3@qt/everywhere: requirement qtbase/[<=6.2.3, include_prerelease=True]@qt/everywhere overridden by qtdeclarative/6.2.3@qt/everywhere to qtbase/6.2.3@qt/everywhere WARN: qtsvg/6.2.3@qt/everywhere: requirement qtbase/[<=6.2.3, include_prerelease=True]@qt/everywhere overridden by qtdeclarative/6.2.3@qt/everywhere to qtbase/6.2.3@qt/everywhere qttools/6.2.3@qt/everywhere: WARN: Package binary is corrupted, removing: 267a94afc3683f3050beb12de35bc442b3c1e5c4Version ranges solved    Version range '<=6.2.3, include_prerelease=True' required by 'qttools/6.2.3@qt/everywhere' resolved to 'qtactiveqt/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qttools/6.2.3@qt/everywhere' resolved to 'qtbase/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qttools/6.2.3@qt/everywhere' resolved to 'qtdeclarative/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qtactiveqt/6.2.3@qt/everywhere' valid for downstream requirement 'qtbase/6.2.3@qt/everywhere'    Version range '<=6.2.3, include_prerelease=True' required by 'qtdeclarative/6.2.3@qt/everywhere' valid for downstream requirement 'qtbase/6.2.3@qt/everywhere'    Version range '<=6.2.3, include_prerelease=True' required by 'qtdeclarative/6.2.3@qt/everywhere' resolved to 'qtimageformats/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qtdeclarative/6.2.3@qt/everywhere' resolved to 'qtshadertools/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qtdeclarative/6.2.3@qt/everywhere' resolved to 'qtsvg/6.2.3@qt/everywhere' in local cache    Version range '<=6.2.3, include_prerelease=True' required by 'qtimageformats/6.2.3@qt/everywhere' valid for downstream requirement 'qtbase/6.2.3@qt/everywhere'    Version range '<=6.2.3, include_prerelease=True' required by 'qtshadertools/6.2.3@qt/everywhere' valid for downstream requirement 'qtbase/6.2.3@qt/everywhere'    Version range '<=6.2.3, include_prerelease=True' required by 'qtsvg/6.2.3@qt/everywhere' valid for downstream requirement 'qtbase/6.2.3@qt/everywhere'
      Installing package: qttools/6.2.3@qt/everywhereRequirements    qtactiveqt/6.2.3@qt/everywhere from 'qt' - Cache    qtbase/6.2.3@qt/everywhere from 'qt' - Cache    qtdeclarative/6.2.3@qt/everywhere from 'qt' - Cache    qtimageformats/6.2.3@qt/everywhere from 'qt' - Cache    qtshadertools/6.2.3@qt/everywhere from 'qt' - Cache    qtsvg/6.2.3@qt/everywhere from 'qt' - Cache    qttools/6.2.3@qt/everywhere from 'qt' - CachePython requires    qt-conan-common/6.2@qt/everywherePackages    qtactiveqt/6.2.3@qt/everywhere:bce947448a5e9b4277401283520f790e157e7e7f - Cache    qtbase/6.2.3@qt/everywhere:515119bcf8bd7063022a92f181e0356e62509f7d - Cache    qtdeclarative/6.2.3@qt/everywhere:948880e263123574cc3e0118184b48571b954864 - Cache    qtimageformats/6.2.3@qt/everywhere:bce947448a5e9b4277401283520f790e157e7e7f - Cache    qtshadertools/6.2.3@qt/everywhere:bce947448a5e9b4277401283520f790e157e7e7f - Cache    qtsvg/6.2.3@qt/everywhere:bce947448a5e9b4277401283520f790e157e7e7f - Cache    qttools/6.2.3@qt/everywhere:267a94afc3683f3050beb12de35bc442b3c1e5c4 - Build
      Installing (downloading, building) binaries...qtbase/6.2.3@qt/everywhere: Already installed!qtactiveqt/6.2.3@qt/everywhere: Already installed!qtactiveqt/6.2.3@qt/everywhere: WARN: Lib folder doesn't exist, can't collect libraries: /home/andrei/.conan/data/qtactiveqt/6.2.3/qt/everywhere/package/bce947448a5e9b4277401283520f790e157e7e7f/libqtimageformats/6.2.3@qt/everywhere: Already installed!qtshadertools/6.2.3@qt/everywhere: Already installed!qtsvg/6.2.3@qt/everywhere: Already installed!qtdeclarative/6.2.3@qt/everywhere: Already installed!qttools/6.2.3@qt/everywhere: WARN: Build folder is dirty, removing it: /home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4qttools/6.2.3@qt/everywhere: Copying sources to build folderqttools/6.2.3@qt/everywhere: Building your package in /home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4qttools/6.2.3@qt/everywhere: Generator txt created conanbuildinfo.txtqttools/6.2.3@qt/everywhere: Aggregating env generatorsqttools/6.2.3@qt/everywhere: Calling build()qttools/6.2.3@qt/everywhere: Using QT_ADDITIONAL_PACKAGES_PREFIX_PATH: /home/andrei/.conan/data/qtactiveqt/6.2.3/qt/everywhere/package/bce947448a5e9b4277401283520f790e157e7e7f;/home/andrei/.conan/data/qtdeclarative/6.2.3/qt/everywhere/package/948880e263123574cc3e0118184b48571b954864;/home/andrei/.conan/data/qtimageformats/6.2.3/qt/everywhere/package/bce947448a5e9b4277401283520f790e157e7e7f;/home/andrei/.conan/data/qtshadertools/6.2.3/qt/everywhere/package/bce947448a5e9b4277401283520f790e157e7e7f;/home/andrei/.conan/data/qtsvg/6.2.3/qt/everywhere/package/bce947448a5e9b4277401283520f790e157e7e7f;/home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/package/515119bcf8bd7063022a92f181e0356e62509f7d;qttools/6.2.3@qt/everywhere: Calling: /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/package/515119bcf8bd7063022a92f181e0356e62509f7d/bin/qt-configure-module /home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4  -- -DQT_BUILD_SINGLE_REPO_TARGET_SET=qttools -DCMAKE_INSTALL_PREFIX=/home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/package/267a94afc3683f3050beb12de35bc442b3c1e5c4 '/home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/package/515119bcf8bd7063022a92f181e0356e62509f7d/bin/qt-cmake-private' '-DQT_BUILD_SINGLE_REPO_TARGET_SET=qttools' '-DCMAKE_INSTALL_PREFIX=/home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/package/267a94afc3683f3050beb12de35bc442b3c1e5c4' '/home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4'-- The CXX compiler identification is GNU 11.2.0-- The C compiler identification is GNU 11.2.0-- Detecting CXX compiler ABI info-- Detecting CXX compiler ABI info - done-- Check for working CXX compiler: /usr/bin/c++ - skipped-- Detecting CXX compile features-- Detecting CXX compile features - done-- Detecting C compiler ABI info-- Detecting C compiler ABI info - done-- Check for working C compiler: /usr/bin/cc - skipped-- Detecting C compile features-- Detecting C compile features - done-- Looking for pthread.h-- Looking for pthread.h - found-- Performing Test CMAKE_HAVE_LIBC_PTHREAD-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Success-- Found Threads: TRUE  -- Check if linker can resolve circular dependencies - FALSE-- Performing Test HAVE_STDATOMIC-- Performing Test HAVE_STDATOMIC - Success-- Found WrapAtomic: TRUE  -- Found OpenGL: /usr/lib/x86_64-linux-gnu/libOpenGL.so   -- Check for feature set changes-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.11") -- Found LibXml2: /usr/lib/x86_64-linux-gnu/libxml2.so (found version "2.9.12") CMake Error at /usr/lib/llvm-13/lib/cmake/clang/ClangTargets.cmake:709 (message):  The imported target "clangBasic" references the file
           "/usr/lib/llvm-13/lib/libclangBasic.a"
        but this file does not exist.  Possible reasons include:
        * The file was deleted, renamed, or moved to another location.
        * An install or uninstall procedure did not complete successfully.
        * The installation package was faulty and contained
           "/usr/lib/llvm-13/lib/cmake/clang/ClangTargets.cmake"
        but not all the files it references.
      Call Stack (most recent call first):  /usr/lib/cmake/clang-13/ClangConfig.cmake:20 (include)  cmake/FindWrapLibClang.cmake:14 (find_package)  /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/build/515119bcf8bd7063022a92f181e0356e62509f7d/cmake/QtFindPackageHelpers.cmake:130 (find_package)  configure.cmake:19 (qt_find_package)  /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/build/515119bcf8bd7063022a92f181e0356e62509f7d/cmake/QtFeature.cmake:573 (include)  src/CMakeLists.txt:21 (qt_feature_evaluate_features)-- Configuring incomplete, errors occurred!See also "/home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4/CMakeFiles/CMakeOutput.log".CMake Error at /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/package/515119bcf8bd7063022a92f181e0356e62509f7d/lib/cmake/Qt6/QtProcessConfigureArgs.cmake:947 (message):  CMake exited with code 1.qttools/6.2.3@qt/everywhere: qttools/6.2.3@qt/everywhere: ERROR: Package '267a94afc3683f3050beb12de35bc442b3c1e5c4' build failedqttools/6.2.3@qt/everywhere: WARN: Build folder /home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4ERROR: qttools/6.2.3@qt/everywhere: Error in build() method, line 404 build_leaf_qt_module(self)while calling 'build_leaf_qt_module', line 48 run_qt_configure_module_with_additional_packages_prefix(while calling 'run_qt_configure_module_with_additional_packages_prefix', line 61 build_env_wrap(conan_file, build_func)while calling 'build_env_wrap', line 76 build_func(conan_file)while calling 'run_qt_configure_module', line 100 conan_file.run(cmd, run_environment=True) ConanException: Error 1 while executing /home/andrei/.conan/data/qtbase/6.2.3/qt/everywhere/package/515119bcf8bd7063022a92f181e0356e62509f7d/bin/qt-configure-module /home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/build/267a94afc3683f3050beb12de35bc442b3c1e5c4  -- -DQT_BUILD_SINGLE_REPO_TARGET_SET=qttools -DCMAKE_INSTALL_PREFIX=/home/andrei/.conan/data/qttools/6.2.3/qt/everywhere/package/267a94afc3683f3050beb12de35bc442b3c1e5c4 
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              iknd Iikka Eklund
              Reporter:
              andymal Andrei Malashkin
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes