Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-42805

Regression: Qt5SerialPort.so depends on libudev

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.4.0
    • Fix Version/s: 5.4.0 RC
    • Labels:
      None
    • Environment:
      qt-opensource-linux-x64-5.4.0-rc_2014-11-20_10-10-31-93.run

      Description

      Qt5SerialPort.so in the Linux binary installers have a hard dependency on libudev.so.0, which is not available by default on more modern distributions.

      This is a regression from Qt 5.3 binaries, likely caused by the installation of a libudev-dev package on the build machines. Please consider removing it again.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kkohne Kai Köhne
              Reporter:
              kkohne Kai Köhne
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes