Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-44763

WebEngine resource loading extremely slow

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.4.0, 5.4.1, 5.4.2, 5.5.0
    • Fix Version/s: 5.5.1
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Windows 7 64bit VS2013 OpenGL LAN network connection

      Description

      When a non-internet connected LAN is enabled QWebEngine's loading of external resources over HTTP, <img> or <script> tags for example, is extremely slow ( >3 seconds per resource).

      Steps to reproduce:
      1. Connect to the internet
      2. Connect an additional LAN (second laptop with no internet connection)
      3. Build and run the NanoBrowser example app

      Disabling/Enabling the LAN instantly fixes/reproduces the issue.

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-44763
          # Subject Branch Project Status CR V

            Activity

              People

              • Assignee:
                kkohne Kai Köhne
                Reporter:
                acutmore Ashley Cutmore
              • Votes:
                18 Vote for this issue
                Watchers:
                19 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes