Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-65882

UI is not rendered when multiple displays are attached

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.9.3, 5.9.4
    • Fix Version/s: None
    • Component/s: GUI: Window management
    • Labels:
      None
    • Environment:
      Windows 10 Pro x64 on Surface Book Pro with 2x FullHD Display attached via DisplayLink Docking Station.

      Description

      The QGuiApplication window stays completely white.

      I was digging for hours to find a solution and stumbled upon https://bugreports.qt.io/browse/QTCREATORBUG-17091. This led me to unplug my two external displays (2x FullHD via Dell D3100 docking station with DisplayLink). Running the code again, everything works. 

      With the displays attached, I can move the application to the Surface Book screen and the moment it hits that frame, the content appears.

        Attachments

        1. MultiDisplayBug_cycling-colors.zip
          784 kB
        2. MultiDisplayBug.zip
          2 kB
        3. qtdiag.txt
          7 kB
        4. white.png
          white.png
          11 kB

          Issue Links

          For Gerrit Dashboard: QTBUG-65882
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              tgurdan Tobias Gurdan
              Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes