Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-78280

[5.13 regression] Can't load flash pepper plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.13.1
    • Fix Version/s: 5.12.7, 5.14.0 RC1
    • Component/s: WebEngine
    • Labels:
    • Environment:
      ArchLinux
      pepper-flash-32.0.0.255
    • Platform/s:
      All, Linux/X11
    • Commits:
      e72fd5136c5a7a848d9156334cf8f067eb1a1a10 (qt/qtwebengine/5.14.0) 5f05d9d1a3e0f30d4e7cccfe2d70387437fcccf3 (qt/qtwebengine/5.12)

      Description

      1. launch simplebrowser (from QtWebEngine's example)
      2. go to URL which contains flash content.
      3. "Couldn't load plugin" show up on the page.
      4. following error message (I assume that it comes from the plugin) show up in console
        [ERROR:flash/platform/pepper/pep_module.cpp(143)] Browser does not support interface PPB_TCPSocket_Private;0.5|PPB_TCPSocket_Private;0.4|PPB_TCPSocket_Private;0.3.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              ztamas Tamas Zakor
              Reporter:
              stream9 stream9 stream9
              Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes