Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-82012

Add plugin placeholder when ppapi can’t be loaded.

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Closed
    • Priority: P4: Low
    • Resolution: Fixed
    • Affects Version/s: 5.15
    • Fix Version/s: 5.15.0
    • Component/s: WebEngine
    • Labels:
      None
    • Platform/s:
      All
    • Commits:
      0bc9942e744d8c7cb3af2707232f2d79ad9bb40b

      Description

      Blink shows an error message in place of the plugin if error occures. With a plugin placeholder, it would look a little bit nicer and it may show more elaborate information.

      For example, if the plugin is not supported:

      ./simplebrowser --register-pepper-plugins="/path/to/libppapi_example_paint_manager.so;application/x-ppapi-example-paint_manager" file:///path/to/ppapi/examples/2d/2d.html
      

       Actual:

       

      Expected:

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              ztamas Tamas Zakor
              Reporter:
              ztamas Tamas Zakor
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes