Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-84473

Qt Device Utilities in Qt 6

    XMLWordPrintable

    Details

    • Epic Name:
      Device Utilities in Qt6
    • Platform/s:
      Linux/Yocto

      Description

      Qt Device Utilities need to be re-packaged so that they can be delivered outside of Qt 6.x releases through Qt Marketplace. Since for time being Marketplace cannot support checking for Qt DC license (QTMP-65) the delivery of DU needs to happen through Online Installer as before.

      While at it it is worth to evaluate if the utilities need cleanup and rearchitecturing for better support of current and future devices.

      The intent is to bring the Device Utilities back in Qt 6.1 release time frame, thus they are available for Qt 5.x users and then from Qt 6.1 time frame onwards for Qt 6 users.

      Packaging and pricing wise the Device Utilities are for users with Qt for Device Creation Developer License.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              rampe Rami Potinkara
              Reporter:
              santtuahonen Santtu Ahonen
              PM Owner:
              Veli-Pekka Heinonen Veli-Pekka Heinonen
              RnD Owner:
              Rami Potinkara Rami Potinkara
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes