Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-91773

[REG] loadFinished signal is sometimes not emitted

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.15.3
    • Fix Version/s: 5.15.5
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Falkon webbrowser.
    • Platform/s:
      Linux/X11
    • Commits:
      4d4fc9cd120376f30ce0630b1e8c7bf174d44fae (qt/qtwebengine/5.15)

      Description

      Hello,

      after updating to QtWebEngine 5.15.3 the loadFinished signal is sometimes not emited and page keeps loading. The page will never stop loading even when we request it to stop with QWebEngineView::stop() function;

      This seems to be related to:

       

      Thank you for your help.

       

      Summary from our bug report: https://bugs.kde.org/show_bug.cgi?id=434203

      > After updating qt5-webengine to 5.15.3-2, some pages do not finish loading in Falkon. Some sites will initially load normally(eg. Youtube), but after navigating to another part of the site (eg. from homepage to subscriptions), never stop loading (despite having seemingly finished) and cannot be stopped/reloaded. Other sites (eg. Twitter) never stop loading at all. Others still (eg. Google) load and navigate normally. <

       

      Thank you for your help.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kiburtse Kirill Burtsev
            Reporter:
            sgorava Juraj Oravec
            Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes