Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-94581 Review and Document new Qt 6.2 CMake API
  3. QTBUG-95018

Change the minimum required CMake version for building and using Qt

    XMLWordPrintable

Details

    • Technical task
    • Status: Closed
    • P2: Important
    • Resolution: Done
    • 6.2.0
    • Build System: CMake
    • None
    • f95a446641ac84c7756d184a7ee996fc538a18c9 (qt/qtbase/dev) f1641ed814462f2333f879f9e7d840303734c9f2 (qt/qtbase/6.2)

    Description

      As discussed in the CMake API review https://git.qt.io/alcroito/qt6-cmake-api-review/-/blob/master/api_review_qt_6_2.md

      For building a shared Qt, the minimum CMake version required should be 3.16. The same applies to user projects projects using that Qt.

      For building a static Qt, the minimum CMake version required should be 3.20. The same applies to user projects projects using that Qt.

      In the static case, we might raise that to 3.21.0 if the stable CMake version is released before the Qt RC.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              alexandru.croitor Alexandru Croitor
              alexandru.croitor Alexandru Croitor
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There are no open Gerrit changes