Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-95601

Remove unnecessary static linking tests based on requiring CMake 3.21

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 6.2
    • Fix Version/s: None
    • Component/s: Build System: CMake
    • Labels:
      None

      Description

      There are various tests at https://github.com/qt/qtbase/blob/2658f95d3c3aafe3d3da20bf02d597f70277cd8f/tests/auto/cmake/test_static_resources/test_static_resources_propagation/CMakeLists.txt

      which check the various work arounds we implemented to support proper linking of static library object in CMake versions older than 3.21.

      Now that we plan to require CMake 3.21 for Qt 6.2 static builds (as per QTBUG-95018), some of those probably shouldn't be kept anymore.

      Once we release Qt 6.2.0 with the increased minimum version requirement and we've validated that everything works correctly and we don't need the old work arounds anymore, we should remove those tests.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              qtbuildsystem Qt Build System Team
              Reporter:
              alexandru.croitor Alexandru Croitor
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes