Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-94581 Review and Document new Qt 6.2 CMake API
  3. QTBUG-95179

Revise qt6_quick3d_bake_lightprobe_hdri after API review

    XMLWordPrintable

    Details

      Description

      Context
      https://git.qt.io/alcroito/qt6-cmake-api-review/-/commit/5313c017d09c51d9034dd62b33f968b9cd54363c#179fb5213a114272e340c63285f9fb35ba530ab8_329_379

      Rename `INTERNAL` option to `__QT_INTERNAL`.

      Clarify naming, does the function need the `quick3d` infix in the function name?
      Could it be renamed to something more generic, in case if there is need for future expansion of the function capabilities, similar to how qt_add_shaders is a swiss army knife?

      qt6_quick3d_internal_bake_lightprobe_hdri should be renamed to _qt_internal_quick3d_bake_lightprobe_hdri

      qt_quick3d_internal_bake_lightprobe_hdri should be removed.

        Attachments

        For Gerrit Dashboard: QTBUG-95179
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            alexandru.croitor Alexandru Croitor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes