Rename `INTERNAL` option to `__QT_INTERNAL`.
Clarify naming, does the function need the `quick3d` infix in the function name?
Could it be renamed to something more generic, in case if there is need for future expansion of the function capabilities, similar to how qt_add_shaders is a swiss army knife?
qt6_quick3d_internal_bake_lightprobe_hdri should be renamed to _qt_internal_quick3d_bake_lightprobe_hdri
qt_quick3d_internal_bake_lightprobe_hdri should be removed.