Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-20317

Custom executable location lost and disabled on restart

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: Qt Creator 4.6.0
    • Fix Version/s: Qt Creator 4.7.0-beta1
    • Component/s: Debugger
    • Labels:
      None
    • Commits:
      64df51bae489b7a5b352bdb196fad1f3620fdcdd

      Description

      Since upgrading to 4.6.0 from 4.5.0, I have found that every time I start Qt, the Run configuration section has lost the custom executable location, and it cannot be edited (there is no field).

      I have to create a new Run configuration, adding the executable location, at which point I can debug as normal. Then when I next start Qt Creator, it refuses to debug because "Cannot debug: Local executable is not set" so I go to the Run section and the executable location field is missing.

      I have attached a screenshot showing the missing field. 

      There is also no value in the creator.user file, it looks like this:

       <value type="QString" key="ProjectExplorer.CustomExecutableRunConfiguration.Executable"></value>

      The Run configuration is a "Custom executable (on GDB server or hardware debugger)", using a manually created kit that uses an OpenOCD type "Bare Metal" Device.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            hjk hjk
            Reporter:
            justyn Justyn B
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes